About ChocoOS Forums Problems and questions UART connection – random signs if any

This topic contains 2 replies, has 2 voices, and was last updated by Patryk Patryk 1 year, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #697

    Bartosz
    Participant

    Hello,

    There is an issue with connection via UART. While being connected to the device using RS232-USB converter (to specify: QinHeng CH340) no signs appears in terminal, or (by pressing RESET button) random signs are received and silence after that.
    Trying to fix the problem I changed the CFG_FREQUENCY_EXTERNAL_CLOCK  value from 25 MHz  to  16 MHz  (Hope I remembered it right after meeting – if not, please correct me) but the problem still exsists.
    I was also thinking about the speed of connection. In the training materials I followed the proper value which is 921600, but there is no such configuration in Windows Device Manager for this device, so settings for device in Windows OS is 9600, or higher, but it’s different than speed given in PuTTY.

    What can be causing this problem? I don’t think it can be something with ChocoOS, because both build, and flash went ok…
    Of course if more details are needed tell me, so I can provide anything You need  🙂

    Greetings
    Bartosz

    • This topic was modified 1 year, 1 month ago by  Bartosz.
    #699
    Patryk
    Patryk
    Keymaster

    Hi,

    Try to decrease the baud rate. You can find it in the oc_streams_cfg.c. Change it to the 460800 value, and check again.

    Of course anytime when you change something in the config, you have to recompile all spaces 🙂

    #700
    Patryk
    Patryk
    Keymaster

    One more question:

    What the version of the Windows you use? The baud rate choosen in the device manager should not be important, but you can also try to set it to maximum available frequency, and then change the definition also in the ChocoOS config (to the same value).

    In general, these symptoms means, that there is a different baud rate in the Windows and in the ChocoOS. Please also ensure, that the project have been correctly built and that the target was correctly flashed, cause it should work with the default configuration 🙂

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.